Author Topic: Error detected form M21 in M11 setup  (Read 1247 times)

eveline

  • Posts: 8
    • View Profile
Error detected form M21 in M11 setup
« on: February 23, 2017, 02:35:23 pm »
Hello,
I've got a problem with connecting mike 21 and mike 11 in Mike Flood. I expect that this error is related to link definitions, but how I have to prepare both models to Mike Flood? Do they have to meet some specific conditions?
Thanks for any help,

Ewelina

Christian Tomsu

  • Posts: 96
    • View Profile
    • SPEKTER GmbH
Re: Error detected form M21 in M11 setup
« Reply #1 on: March 06, 2017, 01:12:44 pm »
Hi Ewelina,

please have a look into your log - files.
MIKE FLOOD creates some of them in the different directories:
at the location where the cple - file is located and
at the location, where the sim11 - file is located.

Usually, you will find a more detailed description of the error there.

Bests Christian
Project management / Modelling / Advisor
SPEKTER GmbH
Herzogenaurach

eveline

  • Posts: 8
    • View Profile
Re: Error detected form M21 in M11 setup
« Reply #2 on: March 23, 2017, 08:21:25 am »
Hi Christian,
Thanks for answer. Information which I have found:

" Initialising River setup
Error detected from M21 in M11 setup
Abnormal completion"

So I think its caused by link definitions. What can I do whith this error?

Best regards,

Ewelina


Mathieu

  • Posts: 94
    • View Profile
Re: Error detected form M21 in M11 setup
« Reply #3 on: March 23, 2017, 10:13:18 am »
Hi,

this error is the one provided in the *.log file created by your coupling file (*.couple). It says the error is located in the river model, so you need to look into the folder where you have saved the river model file (*.sim11), and in this folder you will find another *.log file containing the errors from the river model. This second *.log file will provide the details of the error.

Best regards,
Mathieu

eveline

  • Posts: 8
    • View Profile
Re: Error detected form M21 in M11 setup
« Reply #4 on: March 23, 2017, 01:46:42 pm »
Ok, I have found it. My computer doesn't show extension of the files, and at glance I haven't seen an extension of .log file.
My error is that timeseries ends too early for the applied simulation period.

Thanks for help :)

Ewelina

eveline

  • Posts: 8
    • View Profile
Re: Error detected form M21 in M11 setup
« Reply #5 on: March 29, 2017, 11:48:15 am »
Hi,

Now I have another problem. When I'm trying to create links between m11 and m21 they are look like in the attached picture. I have got rectangular grid, so mike should create links based on markers 1 and 3 in cross sections. I don't know why the links doesn't suits :(
Many thanks for help. 

Ewelina
« Last Edit: March 29, 2017, 11:52:34 am by eveline »

Christian Tomsu

  • Posts: 96
    • View Profile
    • SPEKTER GmbH
Re: Error detected form M21 in M11 setup
« Reply #6 on: April 03, 2017, 03:00:25 pm »
Hi Ewelina,

are there two cross sections close together ?

Bests Christian
Project management / Modelling / Advisor
SPEKTER GmbH
Herzogenaurach

eveline

  • Posts: 8
    • View Profile
Re: Error detected form M21 in M11 setup
« Reply #7 on: April 11, 2017, 08:15:46 am »
Hi Christian,

On downstream there are two cross section close together (50 m) and distance between other cross sections is between 100-400 m. But situation presented at the picture is along whole reach.

Bestes

Ewelina

Christian Tomsu

  • Posts: 96
    • View Profile
    • SPEKTER GmbH
Re: Error detected form M21 in M11 setup
« Reply #8 on: April 11, 2017, 09:28:15 am »
Hi Ewelina,

thus, just to understand:
The green line is MIKE11 branch axis to link, right ?
The red coloured cells blocked out cells, right ?
The red lines are the cross sections, right ?
The magenta coloured cells are the linked MIKE21 cells, right ?

Can you send a larger clip of the model area ?? Is this phenomenon only locally at those two links ?
Could you please display the marker locations 1 and 3 also in the figure ?

Bests Christian
Project management / Modelling / Advisor
SPEKTER GmbH
Herzogenaurach

eveline

  • Posts: 8
    • View Profile
Re: Error detected form M21 in M11 setup
« Reply #9 on: April 11, 2017, 10:30:08 am »
Hi Christian,

Yes, all colours correspond to layers as you described.
Wrong links are just in the one branch (Swedrnia). Others links are ok, but these were prepared by another person and unfortuanetly I can't ask him how he did it.

Many thanks,

Ewelina


Christian Tomsu

  • Posts: 96
    • View Profile
    • SPEKTER GmbH
Re: Error detected form M21 in M11 setup
« Reply #10 on: April 11, 2017, 10:57:13 am »
Hi Ewelina,

I wonder from where the link following the right branch side is coming from ??
I wold say, something is wrong with the definitions of your cross sections. Did you other marker than 1 and 3 ??

Could you send an screenshot from your "Link river branch to MIKE21" submenu ?
Have you updated your cell indices according to the links ?
But, be careful: this function overwrites all manually changed links. If you have done so, you should work firstly in a copy.

Bests Christian

Project management / Modelling / Advisor
SPEKTER GmbH
Herzogenaurach

eveline

  • Posts: 8
    • View Profile
Re: Error detected form M21 in M11 setup
« Reply #11 on: April 11, 2017, 11:31:38 am »
Hi Christian,

The screenshot of the "Link river branch to mike 21" in attachment.
I didn't update cell indices according to the links, where could I do that? But if I do that probably my markrs will be located at the ends of cross sections (valley cross sections) and I thought that it isn't correct if I want 2d modelling in floodplain.

I have just markers 1 and 3, becouse I thought that in mike flood markes 4 and 5 should be replaced by 1 and 3.

Bestes,

Ewelina

Christian Tomsu

  • Posts: 96
    • View Profile
    • SPEKTER GmbH
Re: Error detected form M21 in M11 setup
« Reply #12 on: April 21, 2017, 02:32:27 pm »
Hi Ewelina,

have you solved it already ?
The new MIKE2017 has some possibilities to better check lateral links.

Bests Christian
Project management / Modelling / Advisor
SPEKTER GmbH
Herzogenaurach

eveline

  • Posts: 8
    • View Profile
Re: Error detected form M21 in M11 setup
« Reply #13 on: April 25, 2017, 11:28:34 am »
Hi Christian,

I have changed coordiantes of end points of cross sections. Then I blocked the cells of river, but it didn't help. In the end I created lateral links manually . Now It looks good, but model doesn't work becouse of instability of mike 11 :(
There are some warning in the log file, but the second model with the same geometry and without problematic river works. So probably it's a problem of the reach which I want to introduce. 

Bests,

Ewelina

Christian Tomsu

  • Posts: 96
    • View Profile
    • SPEKTER GmbH
Re: Error detected form M21 in M11 setup
« Reply #14 on: April 28, 2017, 10:00:46 am »
Hi,

sounds that you should have a closer look to the MIKE11 - setup.

Is it running standalone properliy ?
You should test that first with estimated boundary conditions for best and worst case.

Any instabilites can be identified quite quickly.

Bests
Project management / Modelling / Advisor
SPEKTER GmbH
Herzogenaurach