Author Topic: Fatal error: No element to the right of the link ; Abnormal completion  (Read 484 times)

miyuruj

  • Posts: 2
    • View Profile
I'm getting an error notification while simulating MIKE FLOOD module with MIKE 11-HD File and M21FM-mesh as follows. This was prompted for several lateral links.

"Fatal error: No element to the right of the link ; Abnormal completion"

Plus I noticed that some of the river-cross sections have been misaligned in the FLOOD editor (see the attached screenshot) although they are correctly aligned in the M11-network file. I tried deleting and updating those cross-sections in the network file but didn't change anything in the flood editor.

What could be the reason for this and can anybody help on this?

Cheers!

EliasMoussoulis

  • Posts: 9
    • View Profile
Re: Fatal error: No element to the right of the link ; Abnormal completion
« Reply #1 on: November 06, 2018, 06:37:01 pm »
Hi,
The first error is because some parts of the lateral links are falling outside the mesh. It is better to move these just inside the mesh (either by using the "Move Points Mode" button at the Link Editor toolbar or re-creating/importing the lateral links) so that they are correctly read by MIKE FLOOD.

I think the display issue may be because the specific cross-section's coordinates were not defined correctly (in MIKE 11 cross-sections editor). Since MIKE 11 is a 1D model it doesn't actually need the cross-section's coordinates info (cross-sections are placed based on their chainages that's why you see them aligned in the MIKE 11 network file) but these are needed in MIKE FLOOD editor when creating the lateral links or displaying the cross-sections.
Hope this helps.

miyuruj

  • Posts: 2
    • View Profile
Re: Fatal error: No element to the right of the link ; Abnormal completion
« Reply #2 on: November 12, 2018, 10:44:22 am »
Thank You Very Much. :)